Increased latency on infrastructure

Incident Report for Knot

Postmortem

April 6, 2026

Duration: 2 hours, 40 minutes (7:19 PM – 9:59 PM EDT)

What happened

On April 6, 2026 at approximately 7:19 PM EDT, we identified that tasks submitted through our platform were not being processed. This affected all product offerings. 

Root cause

The incident was caused by a regional outage in Google Cloud Tasks, which is responsible for the queuing infrastructure we use to scale our services.

Timeline

  • 7:19 PM - Issue identified by our team.
  • 7:19 PM – 9:30 PM - Investigation and mitigation efforts, including temporarily migrating regions and temporarily disabling certain merchant integrations to prevent user impact.
  • ~9:59 PM - Confirmed the issue was resolved and systems were working as intended. Began processing the backlog.
  • 11:07 PM -  Monitoring was successful. Incident resolved.

Impact

  • Tasks submitted during the incident window experienced significant processing delays.
  • All queued tasks were eventually processed once the alternate region was operational.
  • A small number of card switches could not be retried automatically. Affected users can simply re-initiate their card switch to complete the process.
Posted Apr 07, 2026 - 19:45 UTC

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 02:27 UTC

Monitoring

We have switched cloud regions as google cloud tasks has a confirmed outage on this region.
Posted Apr 07, 2026 - 01:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 07, 2026 - 01:18 UTC

Identified

The issue has been identified at the infra level. Specifically, the issue is related to Google Cloud Tasks in the us-central1 region of Google Cloud Platform and is affecting other businesses.
Posted Apr 07, 2026 - 01:13 UTC

Investigating

We are currently investigating this issue.
Posted Apr 07, 2026 - 00:57 UTC